View Full Version : D-Link Rangebooster N 650 Desktop Adapter Issues

The boy 4rm oz
01-23-2008, 08:06 AM
Well during the week my dad went out and got himself a Belkin N1 MIMO Wi-Fi router for us to use at home. Straight after this I went and upgraded my 54mbps wireless card to the top of the line D-Link Rangebooster N 650 300mbps wireless card.

This is where the story gets interesting. I removed my old card and installed the new one into my PC. I booted up as usual and when Vista (64bit) prompted me to install drivers I inserted the driver disk that came with the card. Just as I thought, the driver disk didn't contain drivers for 64bit Vista so I jumped on my brothers computer, visited the D-Link world wide web site and grabbed myself new drivers. I loaded the drivers up and detected the home network. I connected to the network and after the connection had established my PC locked up and froze. I restarted my PC with the card still installed, logged on and when the network had connected again I was hit by the blue screen of death. "Hardware error, please restart vista to avoid permanent damage to your hardware".

I called customer service and told them everything that had happened. They told me to try it in a different PCI slot (which I had already tried), they then told me to put it in another PC and try again. I put it in my brothers PC and the same thing happened. I was then informed to take the card back to where I got it from for replacement.

Today I took back the card and exchanged it, I connected to the network...and it didn't crash. I used it for about 5 mins before my system locked up and I was forced to restart the PC.

This time I went to the Australian D-Link site and searched for new drivers, they only offered plain Vista drivers so I downloaded them and tried to install them. The installer kept saying that there was no drivers in the file I had selected and wouldn't update. I looked again on the world wide site and found that the drivers I downloaded were for the same product but with a different model number (I downloaded drivers for DWA-542, mine is a DWA-547). The Australian site only lists the DWA-547 where as the world wide site lists DWA-542 and 552. The 542 drivers are the ones I used originally and are the only ones that seemed to allow me to use the device. I have just downloaded the 552 drivers and will try them. Any ideas or help would be great.

Thanks in advance
The boy 4rm oz

The boy 4rm oz
01-23-2008, 08:10 AM
I have just tried the 552 drivers and they do the same thing as the 542 drivers. They just lock up my system. It's bloody smart for a manufacturer to release drivers for their product that don't work, the Vista ones for my exact model code don't even register with the card.

01-23-2008, 10:56 AM

A warning to anyone thinking of buying an 802.11n product based on an Atheros chip - DONT DO IT. Your PC (no matter what OS you are running) will become an unstable piece of garbage the second you install the card (or hook up one of their equally craptastic USB devices like the DWA-142 - which I also own and is also total rubbish).

i got it to work with updated drivers try this :

they are v1.1 and the file is 2 mb bigger installed and runs without a conflict or anything and without a reboot.

you can put in the card before powering on when windows asks to install the new hardware cancel it and start this setup should work fine.



few things i found out :
- the card isnt listed on any of the dlink .com sites because its for europe you will find it listed on european sites.
- the updated drivers arent listed on the european site so dont bother downloading it from there
- the driver i posted here is multi language so dont worrie about the .de domain.

The boy 4rm oz
01-23-2008, 11:00 AM
Thanks for this mate, I have downloaded the file and am about to try it. I'll let you know how it goes.

The boy 4rm oz
01-23-2008, 11:13 AM
This did not work, it wouldn't let me install the driver from the file. +rep for your help anyway.

01-23-2008, 11:25 AM

You need to connect via a hard wired adapter with the wireless still
in the machine. Windows Update will pull down a working driver for
the wireless card. Don't shoot the messenger.

The boy 4rm oz
01-23-2008, 11:31 AM
Ok I'll try this.

EDIT: It has found the driver and is installing now, I'll keep you posted.

The boy 4rm oz
01-23-2008, 11:42 AM
I was halfway through writing how it works when my system locked up. Looks like I will just have to take it back for a cash refund and put up with my ****ty 54mbps wireless card.
Thanks again for your help.