Results 1 to 3 of 3

Thread: EVGA GTX 295 flickering problem solved

  1. #1
    Strip it, paint it, and love on it... Commando's Avatar
    Join Date
    Nov 2006
    Location
    29 Palms CA
    Posts
    589

    Default EVGA GTX 295 flickering problem solved

    I really wanted to share this because it cost me, oh about, 2 months and a ton of heartache.

    I build a monster rig with a watercooled GTX 295 and ever since day one I had serious flickering issues with the video card in SLi mode. (it has 2 cores)

    I searched high and low for a solution across the net to no avail. I RMAed the card twice, didn't help. But the key to figuring it out was the second time I RMAed it worked for a minute or 2 then as soon as I opened the NVidia control panel it started flickering again.

    This is what made me finally figure it out. I had a resident driver for my monitor installed that never really uninstalled when I tried the myriad of driver changes and configs to get it fixed.

    Long story short:

    - Yes the GTX 295 is awesome and works great
    - You should probably start with a fresh install of all drivers and NOT install a resident monitor driver. Also make sure a resident monitor driver wasn't automatically installed.
    - EVGA was really cool about the RMAs but the shipping started adding up.

    My specific setup is as follows:

    - EVGA GTX 295 Water Cooled edition
    - BFG 1200w power supply
    - Acer X222 monitor

    I hope this helps anyone else struggling with this obscure but crazy hard to figure out problem.

    Tony D.

  2. #2
    Water Cooled pcclan's Avatar
    Join Date
    Jan 2009
    Location
    Edmonton,Ab
    Posts
    640

    Default Re: EVGA GTX 295 flickering problem solved

    have you tried different sli thingys
    Quote Originally Posted by lastweek View Post
    Not only will it probably catch fire to your house, it will probably shoot peices out of your case and kill your cat. make sure you video tape your expierment.
    Quote Originally Posted by StormRider View Post
    Write your will before you turn it on
    http://folding.extremeoverclocking.c...?u=555806&bg=1



  3. #3
    woy...collokweee...weeble weeble blaaaat artoodeeto's Avatar
    Join Date
    Oct 2009
    Location
    Simi Valley, California, USA
    Posts
    1,075

    Default Re: EVGA GTX 295 flickering problem solved

    I encountered a similar flickering issue on (originally) my dual 7950GT-dual-20"-Samsung setup under Vista x64. Had a lot of back and forth with Nvidia about it, none of use could figure it out. finally turns out that the problem lay in my screens - there was a bad batch of them that flickered when run off a newer video card at the screen's native res. Didn't flicker at all when set lower than 1600x1200. And only the primary screen flickered, secondary never did. It was bizarre, but getting Powerstrip and minutely adjusting the timings fixed it. But....I now have a single GTX 285 and Windows 7 x64...and powerstrip causes a system crash whenever I try and change the timings. The flickering now happens on the secondary screen, so it's not quite as much of an issue. Luckily I only paid $200 for each screen 2.5 years ago. other than the flicker issue they're fantastic. Oh well...it'll be time for new ones at some point if I can't get Powerstrip going again.
    Quote Originally Posted by ElevateThis View Post
    I'd mod my dog if i could.
    Quote Originally Posted by AmEv View Post
    (Steam me.... that sounds bad >_<)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •